Skip to main content
VulnerabilityPublished Updated

CVE-2026-31704: Linux kernel · ksmbd: use check_add_overflow() to prevent u16 DACL size overflow

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 7.0.0-27.27 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-27.27, 7.0.0-1008.8, 7.0.0-1007.7 +4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinuxpkg:deb/ubuntu/linux@7.0.0-27.27?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-27.27
Fixed in
  • 7.0.0-27.27
Ubuntu 26.04 LTSlinux-awspkg:deb/ubuntu/linux-aws@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1008.8
Fixed in
  • 7.0.0-1008.8
Ubuntu 26.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • 6.17.0-1003.3 – 7.0.0-1009.9
10 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threatsAffected
  • 7.0.0-1003.3 – 7.0.0-1008.8
4 affected builds
Fixed in–
Ubuntu 26.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp@7.0.0-1007.7?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1007.7
Fixed in
  • 7.0.0-1007.7
Ubuntu 26.04 LTSlinux-ibmpkg:deb/ubuntu/linux-ibm@7.0.0-1009.9?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-1009.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released by Ubuntu in their Linux kernel updates (see Ubuntu Security Notices USN-8488-1 and USN-8488-2). Users should update their Linux kernel to versions 6.8.0 and later or the corresponding patched package versions provided by their distribution. After updating, a system reboot is required to apply the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. No additional mitigations are indicated by the vendor advisory.

Description

In the Linux kernel, the following vulnerability has been resolved: ksmbd: use check_add_overflow() to prevent u16 DACL size overflow set_posix_acl_entries_dacl() and set_ntacl_dacl() accumulate ACE sizes in u16 variables. When a file has many POSIX ACL entries, the accumulated size can wrap past 65535, causing the pointer arithmetic (char *)pndace + *size to land within already-written ACEs. Subsequent writes then overwrite earlier entries, and pndacl->size gets a truncated value. Use check_add_overflow() at each accumulation point to detect the wrap before it corrupts the buffer, consistent with existing check_mul_overflow() usage elsewhere in smbacl.c.

References

Community reviews

Loading reviews…