CVE-2026-31729: Linux kernel · usb: typec: ucsi: validate connector number in ucsi_notify_common()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 7.0.0-1006.6 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-nvidia package to 7.0.0-1006.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1006.6?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing this vulnerability is available and should be applied promptly. Users should update their Linux kernel to version 6.8.0 or later (or the corresponding patched builds) via their distribution's standard update mechanisms. After updating, a system reboot is required to apply the changes. Due to an ABI change in the kernel update, all third-party kernel modules must be recompiled and reinstalled. Follow vendor instructions carefully to ensure complete remediation.
Description
A vulnerability in the Linux kernel's USB Type-C Connector System Software Interface (UCSI) was resolved by adding validation for connector numbers in the ucsi_notify_common() function. The issue involved an out-of-bounds array access caused by a connector number extracted from hardware that could exceed the allocated array size. This flaw could be triggered by a malicious or malfunctioning device reporting an invalid connector number. The vulnerability has a high severity with a CVSS score of 7.8 and affects multiple Linux kernel versions prior to 6.8.0 and related builds. A patch is available and should be applied via standard system updates, which require a reboot and recompilation of third-party kernel modules due to ABI changes.
References
- ubuntu.com/security/CVE-2026-31729 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-31729 (opens in a new tab)
- git.kernel.org/linus/d2d8c17ac01a1b1f638ea5d340a884ccc5015186 (opens in a new tab)
- ubuntu.com/security/notices/USN-8567-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8596-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8606-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8607-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8608-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8609-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8574-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8595-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8619-1 (opens in a new tab)