CVE-2026-31777: Linux kernel · ALSA: ctxfi: Check the error for index mapping
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium : upgrade to 7.0.0-1006.6 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-nvidia package to 7.0.0-1006.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde@7.0.0-1008.8?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlinux-nvidiapkg:deb/ubuntu/linux-nvidia@7.0.0-1006.6?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-40.40?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1019.19?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1020.20?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to Linux kernel versions prior to 7.0.0-1006.6 to address this vulnerability. Users should update to version 7.0.0-1006.6 or later where the issue is fixed by adding proper error checking in the ALSA ctxfi driver.
Description
A vulnerability in the Linux kernel ALSA ctxfi driver was resolved by adding proper error checking for the function daio_device_index(). Previously, the driver assumed this function always returned a valid value, which is not guaranteed. This flaw could lead to an availability impact. The issue affects Linux kernel versions prior to 7.0.0-1006.6. A patch is available to address this problem.