CVE-2026-31953: xibosignage xibo-cms · Cross-site Scripting
Affects xibosignage xibo-cmsSource CVE Database V5
Not known to be exploited · CVSS 6.4 Medium : upgrade to 4.4.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade xibo-cms and xibosignage/xibo-cms to 4.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| xibosignagexibo-cms | Affected
| Fixed in
|
GitHubxibosignage/xibo-cmspkg:github/xibosignage/xibo-cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade xibo-cms to version 4.4.1 or later, which fixes this vulnerability. If upgrading is not immediately possible, restrict notification creation and notification center access privileges to trusted users only, as these privileges are required to exploit the vulnerability.
Description
A stored Cross-Site Scripting (XSS) vulnerability exists in xibo-cms versions prior to 4.4.1. An authenticated user with notification creation permissions can inject arbitrary JavaScript into notification bodies. When such a notification is set as an "interrupt," the script executes automatically in the browser of any targeted user upon login without requiring user interaction. This vulnerability requires privileges that are not granted to non-admin users by default. The issue is fixed in version 4.4.1.