Skip to main content
VulnerabilityPublished Updated

CVE-2026-32107: neutrinolabs xrdp · Improper Check for Dropped Privileges

Affects neutrinolabs xrdpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 0.10.6 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade xrdp and neutrinolabs/xrdp to 0.10.6.

Affected software

ProductAffectedFixed in
neutrinolabsxrdpAffected
  • <0.10.6
Fixed in
  • 0.10.6
GitHubneutrinolabs/xrdppkg:github/neutrinolabs/xrdpOther threatsAffected
  • <0.10.6
Fixed in
  • 0.10.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade neutrinolabs xrdp to version 0.10.6 or later, where this vulnerability has been fixed. Since the vendor advisory confirms the fix in 0.10.6, applying this update fully mitigates the issue. No additional mitigations are indicated.

Description

xrdp is an open source RDP server. In versions through 0.10.5, the session execution component did not properly handle an error during the privilege drop process. This improper privilege management could allow an authenticated local attacker to escalate privileges to root and execute arbitrary code on the system. An additional exploit would be needed to facilitate this. This issue has been fixed in version 0.10.6.

References

Community reviews

Loading reviews…