Skip to main content
VulnerabilityPublished

CVE-2026-32272: craftcms commerce · SQL Injection

Affects craftcms commerceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 5.6.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.6.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade craftcms commerce to 5.6.0.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.6.0
Fixed in
  • 5.6.0

AI-suggested

This vulnerability has been fixed in Craft Commerce version 5.6.0. Users should upgrade to version 5.6.0 or later to remediate this issue. Patch status is not explicitly stated in the vendor advisory, but the fix is included in version 5.6.0. Until upgraded, restrict authenticated control panel access to trusted users only.

Description

An SQL injection vulnerability (CWE-89) exists in Craft Commerce versions 5.0.0 through 5.5.4. The issue arises because the hasVariant and hasProduct properties bypass input sanitization, allowing authenticated control panel users to perform boolean-based blind SQL injection. This can lead to extraction of arbitrary database contents, including security keys that could be used to forge admin sessions and escalate privileges. The vulnerability was fixed in version 5.6.0.

References

Community reviews

Loading reviews…