CVE-2026-32278: opensource-workshop connect-cms · Unrestricted File Upload
Affects opensource-workshop connect-cmsSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 2.41.1 or 1.41.1 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.41.1, 1.41.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 23 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade connect-cms to 2.41.1 or 1.41.1; opensource-workshop/connect-cms to 1.41.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| opensource-workshopconnect-cms | Affected
| Fixed in
|
GitHubopensource-workshop/connect-cmspkg:github/opensource-workshop/connect-cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade Connect-CMS to versions 1.41.1 or 2.41.1 or later, where the patch has been applied. If immediate upgrade is not feasible, administrators should implement strict file upload restrictions at the web server or application firewall level, allowing only safe file types and scanning uploads for malicious content. Input validation and output encoding should be enforced to prevent script injection. Additionally, deploying Content Security Policy (CSP) headers can help mitigate the impact of stored XSS by restricting script execution sources. User education to recognize phishing attempts and suspicious links can reduce the likelihood of user interaction leading to exploitation. Regular security audits and monitoring for unusual file uploads or web traffic patterns can help detect attempted exploitation. Finally, ensure that all other CMS plugins and dependencies are kept up to date to reduce the attack surface.
Description
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
References
- github.com/opensource-workshop/connect-cms/security/advisories/GHSA-mv3p-7p89-wq9p (opens in a new tab)
- github.com/opensource-workshop/connect-cms/commit/9d87fe8ecf7f57efbb0e5231be058807734c96b3 (opens in a new tab)
- github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1 (opens in a new tab)
- github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1 (opens in a new tab)