CVE-2026-32288: Go standard library archive/tar · Uncontrolled Resource Consumption
Affects Go standard library archive/tarSource CVE Database V5
Not known to be exploited · CVSS 5.5 Medium : upgrade to 1.26.2 or 1.25.9 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.26.2, 1.25.9
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Go standard library archive/tar to 1.26.2 or 1.25.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Go standard libraryarchive/tar | Affected
| Fixed in
|
| Go standard libraryarchive/tar | Affected
| Fixed in
|
Goarchive/tarpkg:golang/archive/tarOther threats | Affected
| Fixed in
|
Gogithub.com/golang/go/src/archive/tarpkg:golang/github.com/golang/go/src/archive/tarOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should avoid processing untrusted tar archives containing sparse regions encoded with the old GNU sparse map format or implement application-level resource limits to mitigate potential memory exhaustion.
Description
CVE-2026-32288 is a medium severity vulnerability in the Go standard library's archive/tar package. The tar.Reader component can consume an unbounded amount of memory when processing malicious tar archives with many sparse regions encoded using the old GNU sparse map format. This can lead to denial of service due to excessive memory use. The vulnerability affects Go versions up to 1.26.0-0.