Skip to main content
VulnerabilityPublished

CVE-2026-32682: F5 NGINX Gateway Fabric · Improper Validation of Array Index

Affects F5 NGINX Gateway FabricSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.6.4 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade F5 NGINX Gateway Fabric to 2.6.4.

Affected software

ProductAffectedFixed in
F5NGINX Gateway FabricAffected
  • >=1.3.0 <2.6.4
Fixed in
  • 2.6.4

Description

CVE-2026-32682 is a medium severity vulnerability in F5 NGINX Gateway Fabric version 1.3.0. It involves improper validation of array indexes (CWE-129) when the product is configured using GRPCRoutes. An authenticated remote attacker with permission to create or modify GRPCRoute resources can cause the control plane to terminate by submitting crafted GRPCRoute configurations containing backendRef filters.

References

Community reviews

Loading reviews…