Skip to main content
VulnerabilityPublished

CVE-2026-33006: Apache HTTP Server · Timing Side Channel

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 2.4.67 when convenient.

Data as of 1 Nov 2026, 11:02 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade apache/httpd to 2.4.67.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • <=2.4.66
Fixed in–
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.67
Fixed in
  • 2.4.67

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users are recommended to upgrade Apache HTTP Server to version 2.4.67, which addresses this timing attack vulnerability. Since the vendor advisory indicates an upgrade path, applying this official fix is the primary mitigation. Patch status is not explicitly confirmed beyond the upgrade recommendation, so users should verify the vendor advisory for the latest remediation details.

Description

A timing attack against mod_auth_digest in Apache HTTP Server 2.4.66 allows a bypass of Digest authentication by a remote attacker. Users are recommended to upgrade to version 2.4.67, which fixes this issue.

References

Community reviews

Loading reviews…