CVE-2026-33019: saitoha libsixel · Out-of-bounds Read
Affects saitoha libsixelSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 1.8.7-r1 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.7-r1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade saitoha libsixel to 1.8.7-r1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| saitohalibsixel | Affected
| Fixed in
|
GitHubsaitoha/libsixelpkg:github/saitoha/libsixelOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in libsixel version 1.8.7-r1. Users and administrators should upgrade to this version or later to remediate the vulnerability. No other mitigation or workaround is indicated in the available data.
Description
libsixel versions prior to 1.8.7-r1 contain an integer overflow vulnerability in the --crop option handling of img2sixel. This flaw allows an out-of-bounds heap read when processing specially crafted crop arguments with positive coordinates up to INT_MAX, leading to a crash and potential information disclosure. The issue arises because the calculation of clip boundaries overflows and bypasses bounds checking, causing memory beyond the image buffer to be accessed. This vulnerability has been fixed in version 1.8.7-r1.