Skip to main content
VulnerabilityPublished Updated

CVE-2026-33044: home-assistant core · Cross-site Scripting

Affects home-assistant coreSource CVE Database V5

0
Compare

Public exploit available · CVSS 7.3 High : upgrade to 2026.01 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.01
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade core and home-assistant-core to 2026.01.

Affected software

ProductAffectedFixed in
home-assistantcoreAffected
  • >=2020.02 <2026.01
Fixed in
  • 2026.01
PyPIhome-assistant-corepkg:pypi/home-assistant-coreOther threatsAffected
  • >=2020.02 <2026.01
Fixed in
  • 2026.01

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Home Assistant core to version 2026.01 or later, where this vulnerability is fixed. Since this is an authenticated attack vector, restricting user permissions may reduce risk but does not fully mitigate the issue. Patch status is confirmed fixed in version 2026.01.

Description

Home Assistant is open source home automation software that puts local control and privacy first. Starting in version 2020.02 and prior to version 2026.01, an authenticated party can add a malicious name to their device entity, allowing for Cross-Site Scripting attacks against anyone who can see a dashboard with a Map-card which includes that entity. It requires that the victim hovers over an information point. Version 2026.01 fixes the issue.

References

Community reviews

Loading reviews…