Skip to main content
VulnerabilityPublished

CVE-2026-33212: WeblateOrg weblate · Improper Access Control

Affects WeblateOrg weblateSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.1 Low : upgrade to 5.17 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.17
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade weblate and weblateorg/weblate to 5.17.

Affected software

ProductAffectedFixed in
WeblateOrgweblateAffected
  • <5.17
Fixed in
  • 5.17
GitHubweblateorg/weblatepkg:github/weblateorg/weblateOther threatsAffected
  • <5.17
Fixed in
  • 5.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Weblate to version 5.17 or later where this vulnerability is fixed. No other mitigation is indicated or required.

Description

Weblate is a web based localization tool. In versions prior to 5.17, the tasks API didn't verify user access for pending tasks. This could expose logs of in-progress operations to users who don't have access to given scope. The attacker needs to brute-force the random UUID of the task, so exploiting this is unlikely with the default API rate limits. This issue has been fixed in version 5.17.

References

Community reviews

Loading reviews…