Skip to main content
VulnerabilityPublished Updated

CVE-2026-33229: xwiki-platform · Missing Authorization

Affects xwiki-platformSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 17.10.1 or 17.4.8 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.10.1, 17.4.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade xwiki-platform and xwiki-platform-legacy-oldcore and xwiki-platform-oldcore and org.xwiki/xwiki-platform to 17.10.1 or 17.4.8.

Affected software

ProductAffectedFixed in
xwikixwiki-platformAffected
  • >=17.5.0-rc-1 <17.10.1
Fixed in
  • 17.10.1
xwikixwiki-platformAffected
  • >=17.0.0-rc-1 <17.4.8
Fixed in
  • 17.4.8
org.xwiki.platformxwiki-platform-legacy-oldcoreAffected
  • >=17.5.0-rc-1 <17.10.1
Fixed in
  • 17.10.1
org.xwiki.platformxwiki-platform-legacy-oldcoreAffected
  • >=17.0.0-rc-1 <17.4.8
Fixed in
  • 17.4.8
org.xwiki.platformxwiki-platform-oldcoreAffected
  • >=17.5.0-rc-1 <17.10.1
Fixed in
  • 17.10.1
org.xwiki.platformxwiki-platform-oldcoreAffected
  • >=17.0.0-rc-1 <17.4.8
Fixed in
  • 17.4.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in XWiki Platform versions 17.4.8 and 17.10.1. Users should upgrade to one of these versions or later to remediate the issue. Since the vulnerability requires script rights, it is also recommended to restrict granting script rights to trusted users only. Patch status is confirmed fixed in the specified versions; no other remediation level is indicated.

Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.

References

Community reviews

Loading reviews…