Skip to main content
VulnerabilityPublished

CVE-2026-33235: Significant-Gravitas AutoGPT · Uncontrolled Resource Consumption

Affects Significant-Gravitas AutoGPTSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 0.6.52 soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.52
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade AutoGPT and significant-gravitas/AutoGPT to 0.6.52.

Affected software

ProductAffectedFixed in
Significant-GravitasAutoGPTAffected
  • >=0.1.0 <0.6.52
Fixed in
  • 0.6.52
GitHubsignificant-gravitas/AutoGPTpkg:github/significant-gravitas/AutoGPTOther threatsAffected
  • <0.6.52
Fixed in
  • 0.6.52

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade AutoGPT to version 0.6.52 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are indicated. Manual administrative intervention is required to recover from exploitation in affected versions.

Description

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. In versions prior to 0.6.52, the Fill Text Template block is vulnerable to a Denial of Service (DoS) attack. While the backend implements a SandboxedEnvironment to prevent unauthorized attribute access (e.g., blocking __class__), it fails to limit the computational complexity or execution time of the expressions. An attacker can input computationally expensive Python/Jinja2 expressions that consume the server's CPU and memory, leading to a complete system hang or crash. In multi-tenant or self-hosted environments, this results in a complete service outage and "noisy neighbor" effects that require manual administrative intervention to recover. This issue has been fixed in version 0.6.52.

References

Community reviews

Loading reviews…