Skip to main content
VulnerabilityPublished

CVE-2026-33324: dataease SQLBot · SQL Injection

Affects dataease SQLBotSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 1.7.1 as a priority.

Data as of 2 Nov 2026, 10:58 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade SQLBot and dataease/SQLBot to 1.7.1.

Affected software

ProductAffectedFixed in
dataeaseSQLBotAffected
  • <1.7.1
Fixed in
  • 1.7.1
GitHubdataease/SQLBotpkg:github/dataease/SQLBotOther threatsAffected
  • <1.7.1
Fixed in
  • 1.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SQLBot to version 1.7.1 or later, where this vulnerability is fixed. Since this is not a cloud service, remediation depends on applying the official patch. Patch status is not explicitly stated in the vendor advisory but the description confirms the issue is fixed in 1.7.1. No other mitigations are indicated.

Description

SQLBot is an intelligent Text-to-SQL system based on large language models and RAG. In versions 1.7.0 and earlier, the Text2SQL chat interface is vulnerable to prompt injection. The user-provided question parameter is directly concatenated into the LLM prompt without filtering or escaping, and the SQL extracted from the LLM response is executed against the database without validation or sanitization. An authenticated attacker can craft a malicious question to manipulate the LLM into generating and executing arbitrary SQL statements. When connected to a PostgreSQL data source, this can lead to remote code execution via COPY FROM PROGRAM. This issue has been fixed in version 1.7.1.

References

Community reviews

Loading reviews…