CVE-2026-33337: FirebirdSQL firebird · Classic Buffer Overflow
Affects FirebirdSQL firebirdSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 5.0.4 : patch FirebirdSQL firebird soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.4, 4.0.7, 3.0.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade firebird and firebirdsql/firebird to 5.0.4, 4.0.7 or 3.0.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FirebirdSQLfirebird | Affected
| Fixed in
|
| FirebirdSQLfirebird | Affected
| Fixed in
|
| FirebirdSQLfirebird | Affected
| Fixed in
|
GitHubfirebirdsql/firebirdpkg:github/firebirdsql/firebirdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been fixed in FirebirdSQL versions 3.0.14, 4.0.7, and 5.0.4. Users should upgrade to one of these versions or later to remediate the issue. Patch status is confirmed by the vendor's versioning information. No additional mitigations are specified or required beyond applying the official updates.
Description
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when deserializing a slice packet, the xdr_datum() function does not validate that a cstring length conforms to the slice descriptor bounds, allowing a cstring longer than the allocated buffer to overflow it. An unauthenticated attacker can exploit this by sending a crafted packet to the server, potentially causing a crash or other security impact. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
References
- github.com/FirebirdSQL/firebird/security/advisories/GHSA-89mq-229g-x47p (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v3.0.14 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v4.0.7 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v5.0.4 (opens in a new tab)