Skip to main content
VulnerabilityPublished

CVE-2026-33386: OpenSolution QuickCMS · XSS or 'Cross-site Scripting'

Affects OpenSolution QuickCMSSource CVE Database V5

0

Not known to be exploited · CVSS 2.3 Low · patch available : update OpenSolution QuickCMS when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
OpenSolutionQuickCMSAffected
  • <=6.8
Fixed in–

AI-suggested

A patch fixing this vulnerability was released in QuickCMS version 6.8 on 2026-05-15. Users should upgrade to version 6.8 or later to remediate this issue. Since no official remediation level or vendor advisory link is provided, verify the patch availability from OpenSolution's official sources. Deployments not updated remain vulnerable. No additional mitigations are specified.

Description

QuickCMS is vulnerable to Cross-Site Scripting (XSS) through its insecure HTTP-based plugin‑fetching mechanism. A malicious attacker can perform a Man‑in‑the‑Middle (MITM) attack by impersonating the opensolution.org server and serving arbitrary HTML or JavaScript at the plugin list endpoint. When a user accesses the plugin page, the malicious content is automatically fetched, rendered, and executed. This issue was fixed in a patch to version 6.8 published on 15.05.2026, deployments without this patch are still vulnerable.

References

Community reviews

Loading reviews…