Skip to main content
VulnerabilityPublished

CVE-2026-33406: pi-hole web · Cross-site Scripting

Affects pi-hole webSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 6.5 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade web and pi-hole/web to 6.5.

Affected software

ProductAffectedFixed in
pi-holewebAffected
  • >=6.0 <6.5
Fixed in
  • 6.5
GitHubpi-hole/webpkg:github/pi-hole/webOther threatsAffected
  • >=6.0 <6.5
Fixed in
  • 6.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Pi-hole version 6.5. Users should upgrade to version 6.5 or later to remediate this issue. There is no indication that temporary mitigations or workarounds are available. Patch status is not explicitly confirmed beyond the fix in version 6.5, so users should consult the vendor's official advisory for current remediation guidance.

Description

CVE-2026-33406 is a medium severity cross-site scripting (XSS) vulnerability in the Pi-hole Admin Interface web application versions 6.0 up to but not including 6.5. It arises from improper neutralization of input when configuration values from the /api/config endpoint are inserted directly into HTML attribute values without escaping, allowing injection of HTML attributes. Although JavaScript execution is blocked by the server's Content Security Policy (CSP), the injected attributes can manipulate element styling, enabling UI redressing attacks. The main attack vector is importing a malicious teleporter backup, which circumvents per-field server-side validation. This vulnerability has been fixed in Pi-hole version 6.5.

References

Community reviews

Loading reviews…