Skip to main content
VulnerabilityPublished

CVE-2026-33435: WeblateOrg weblate · Relative Path Traversal

Affects WeblateOrg weblateSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 5.17 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.17
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade weblate and weblateorg/weblate to 5.17.

Affected software

ProductAffectedFixed in
WeblateOrgweblateAffected
  • <5.17
Fixed in
  • 5.17
GitHubweblateorg/weblatepkg:github/weblateorg/weblateOther threatsAffected
  • <5.17
Fixed in
  • 5.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version (5.17) is available and should be applied to remediate this vulnerability. If immediate upgrade is not possible, restrict access to the project backup feature to trusted users only, as only users with project creation rights can access this functionality. This limits the attack surface until patching is performed.

Description

Weblate is a web based localization tool. In versions prior to 5.17, the project backup didn't filter Git and Mercurial configuration files which could lead to remote code execution under certain circumstances. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can limit the scope of the vulnerability by restricting access to the project backup, as it is only accessible to users who can create projects.

References

Community reviews

Loading reviews…