Skip to main content
VulnerabilityPublished Updated

CVE-2026-33454: Apache Camel · Deserialization of Untrusted Data

Affects Apache CamelSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 9.4 Critical : upgrade to 4.18.1 or 4.14.6 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.4% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.18.1, 4.14.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache Camel and org.apache.camel/camel-mail and Apache Software Foundation/org.apache.camel:camel-mail to 4.18.1 or 4.14.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CamelAffected
  • >=4.15.0 <4.18.1
Fixed in
  • 4.18.1
Apache Software FoundationApache CamelAffected
  • >=3.0.0 <4.14.6
Fixed in
  • 4.14.6
Mavenorg.apache.camel/camel-mailpkg:maven/org.apache.camel/camel-mailOther threatsAffected
  • <4.14.6
  • >=4.15.0
  • <4.18.1
Fixed in
  • 4.14.6
  • 4.18.1
MavenApache Software Foundation/org.apache.camel:camel-mailpkg:maven/Apache Software Foundation/org.apache.camel:camel-mailOther threatsAffected
  • >=3.0.0 <4.14.6
  • >=4.15.0 <4.18.1
Fixed in
  • 4.14.6
  • 4.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrades are available to remediate this vulnerability. Users should upgrade to Apache Camel version 4.19.0, or if using the 4.18.x LTS stream, upgrade to 4.18.1, and if using the 4.14.x LTS stream, upgrade to 4.14.6. These versions include fixes for the header injection issue. No alternative mitigations or temporary workarounds are indicated in the vendor advisory. Patch status is confirmed by vendor advisories from Red Hat.

Description

The Camel-Mail component is vulnerable to Camel message header injection. The custom header filter strategy used by the component (MailHeaderFilterStrategy) only filters the 'out' direction via setOutFilterStartsWith, while it does not configure the 'in' direction via setInFilterStartsWith. As a result, when a Camel application consumes mail through camel-mail (for example via from(\"imap://...\") or from(\"pop3://...\")) the inbound filter check is skipped and Camel-prefixed MIME headers are mapped unfiltered into the Exchange. An attacker who can deliver an email to a mailbox monitored by such a consumer can inject Camel-specific headers that, for some Camel components downstream of the mail consumer (such as camel-bean, camel-exec, or camel-sql), can alter the behaviour of the route. This is the same pattern that was previously addressed in camel-undertow (CVE-2025-30177) and the broader incoming-header filter (CVE-2025-27636 and CVE-2025-29891). This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.1. Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.18.x LTS releases stream, then they are suggested to upgrade to 4.18.1. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6.

References

Community reviews

Loading reviews…