Skip to main content
VulnerabilityPublished Updated

CVE-2026-33496: ory oathkeeper · Improper Validation of Unsafe Equivalence in Input

Affects ory oathkeeperSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 26.2.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.2.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade oathkeeper and ory/oathkeeper to 26.2.0.

Affected software

ProductAffectedFixed in
oryoathkeeperAffected
  • <26.2.0
Fixed in
  • 26.2.0
GitHubory/oathkeeperpkg:github/ory/oathkeeperOther threatsAffected
  • <26.2.0
Fixed in
  • 26.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of ORY Oathkeeper is available starting from version 26.2.0, which addresses the vulnerability by including the introspection server URL in the cache key. Users should update to version 26.2.0 or later. If upgrading immediately is not feasible, it is recommended to disable caching for oauth2_introspection authenticators to prevent exploitation.

Description

ORY Oathkeeper is an Identity & Access Proxy (IAP) and Access Control Decision API that authorizes HTTP requests based on sets of Access Rules. Versions prior to 26.2.0 are vulnerable to authentication bypass due to cache key confusion. The `oauth2_introspection` authenticator cache does not distinguish tokens that were validated with different introspection URLs. An attacker can therefore legitimately use a token to prime the cache, and subsequently use the same token for rules that use a different introspection server. Ory Oathkeeper has to be configured with multiple `oauth2_introspection` authenticator servers, each accepting different tokens. The authenticators also must be configured to use caching. An attacker has to have a way to gain a valid token for one of the configured introspection servers. Starting in version 26.2.0, Ory Oathkeeper includes the introspection server URL in the cache key, preventing confusion of tokens. Update to the patched version of Ory Oathkeeper. If that is not immediately possible, disable caching for `oauth2_introspection` authenticators.

References

Community reviews

Loading reviews…