CVE-2026-33510: homarr · Improper Neutralization of Alternate XSS Syntax
Affects homarrSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.57.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.57.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade homarr and homarr-labs/homarr to 1.57.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| homarr-labshomarr | Affected
| Fixed in
|
GitHubhomarr-labs/homarrpkg:github/homarr-labs/homarrOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade homarr to version 1.57.0 or later, where this vulnerability is fixed. Since the vulnerability is resolved in the official release, applying this update fully mitigates the risk. No additional vendor advisory or patch links are provided, but the version upgrade is the confirmed remediation.
Description
Homarr is an open-source dashboard. Prior to 1.57.0, a DOM-based Cross-Site Scripting (XSS) vulnerability has been discovered in Homarr's /auth/login page. The application improperly trusts a URL parameter (callbackUrl), which is passed to redirect and router.push. An attacker can craft a malicious link that, when opened by an authenticated user, performs a client-side redirect and executes arbitrary JavaScript in the context of their browser. This could lead to credential theft, internal network pivoting, and unauthorized actions performed on behalf of the victim. This vulnerability is fixed in 1.57.0.