Skip to main content
VulnerabilityPublished Updated

CVE-2026-33516: neutrinolabs xrdp · Out-of-bounds Read

Affects neutrinolabs xrdpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 0.10.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade xrdp and neutrinolabs/xrdp to 0.10.6.

Affected software

ProductAffectedFixed in
neutrinolabsxrdpAffected
  • <0.10.6
Fixed in
  • 0.10.6
GitHubneutrinolabs/xrdppkg:github/neutrinolabs/xrdpOther threatsAffected
  • <0.10.6
Fixed in
  • 0.10.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade xrdp to version 0.10.6 or later, where this vulnerability has been fixed. No other official remediation or temporary fixes are indicated. Patch status is confirmed by the vendor's versioning information.

Description

xrdp is an open source RDP server. Versions through 0.10.5 contain an out-of-bounds read vulnerability during the RDP capability exchange phase. The issue occurs when memory is accessed before validating the remaining buffer length. A remote, unauthenticated attacker can trigger this vulnerability by sending a specially crafted Confirm Active PDU. Successful exploitation could lead to a denial of service (process crash) or potential disclosure of sensitive information from the process memory. This issue has been fixed in version 0.10.6.

References

Community reviews

Loading reviews…