Skip to main content
VulnerabilityPublished Updated

CVE-2026-33526: squid · Use After Free

Affects squidSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.2 Critical : upgrade to 7.5 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
9.0% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade squid and squid-cache/squid to 7.5.

Affected software

ProductAffectedFixed in
squid-cachesquidAffected
  • <7.5
Fixed in
  • 7.5
GitHubsquid-cache/squidpkg:github/squid-cache/squidOther threatsAffected
  • <7.5
Fixed in
  • 7.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official fix is available in Squid version 7.5. Users should upgrade to version 7.5 or later to remediate this vulnerability. Red Hat has released security updates for affected Enterprise Linux versions; applying these vendor-provided patches is recommended. Since denying ICP queries via icp_access rules does not mitigate the issue, upgrading or patching is the only effective remediation.

Description

Squid is a caching proxy for the Web. Prior to version 7.5, due to heap Use-After-Free, Squid is vulnerable to Denial of Service when handling ICP traffic. This problem allows a remote attacker to perform a reliable and repeatable Denial of Service attack against the Squid service using ICP protocol. This attack is limited to Squid deployments that explicitly enable ICP support (i.e. configure non-zero `icp_port`). This problem _cannot_ be mitigated by denying ICP queries using `icp_access` rules. Version 7.5 contains a patch.

References

Community reviews

Loading reviews…