Skip to main content
VulnerabilityPublished Updated

CVE-2026-33554: freeipmi · CVE-2026-33554 is a high-severity

Affects freeipmiSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 1.6.17 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.17, 1.16.17
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade FreeIPMI to 1.6.17; the Debian debian/freeipmi package to 1.16.17.

Affected software

ProductAffectedFixed in
FreeIPMIFreeIPMIAffected
  • >=0.7.12 <1.6.17
Fixed in
  • 1.6.17
Debiandebian/freeipmipkg:deb/debian/freeipmiOther threatsAffected
  • <1.16.17
Fixed in
  • 1.16.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-33554, organizations should first verify if they use FreeIPMI versions prior to 1.16.17 and identify affected hardware models from Dell, Supermicro, and Wistron. Immediate steps include restricting network access to IPMI interfaces by implementing strict firewall rules and network segmentation to limit exposure to trusted management networks only. Disable or restrict usage of the vulnerable ipmi-oem subcommands if possible. Monitor IPMI logs for unusual or unexpected OEM command activity. Where feasible, upgrade FreeIPMI to version 1.16.17 or later once available to apply the official fix. If patching is delayed, consider deploying intrusion detection or prevention systems with custom signatures to detect malformed IPMI OEM responses indicative of exploitation attempts. Additionally, enforce strong authentication and encryption on IPMI interfaces to reduce unauthorized access risk, even though this vulnerability does not require authentication. Regularly audit and update IPMI firmware and management tools to minimize exposure to similar vulnerabilities.

Description

CVE-2026-33554 is a high-severity vulnerability in FreeIPMI's ipmi-oem client prior to version 1.16.17, involving exploitable buffer overflows in response messages for specific OEM commands. The affected commands target Dell, Supermicro, and Wistron servers, allowing attackers to potentially cause denial of service or crash the IPMI management interface. The vulnerability requires no authentication or user interaction and can be exploited remotely over the network. While it does not impact confidentiality or integrity directly, it severely affects availability of IPMI services. No known exploits are currently reported in the wild. Organizations using FreeIPMI with affected hardware should prioritize patching or mitigating exposure to IPMI interfaces. Countries with significant use of Dell, Supermicro, and Wistron server hardware are at higher risk.

References

Community reviews

Loading reviews…