CVE-2026-33618: chamilo-lms · Eval Injection
Affects chamilo-lmsSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.0.0-RC.3 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.0-RC.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade chamilo-lms to 2.0.0-RC.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| chamilochamilo-lms | Affected
| Fixed in
|
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Chamilo LMS to version 2.0.0-RC.3 or later, where this vulnerability is fixed. If upgrading immediately is not possible, restrict admin access tightly to trusted users to prevent code injection. Monitor for any suspicious activity related to the /platform-config/list endpoint. Patch status is not explicitly confirmed beyond the version fix, so consult the vendor advisory for the latest remediation guidance.
Description
Chamilo LMS is a learning management system. Prior to .0.0-RC.3, the PlatformConfigurationController::decodeSettingArray() method uses PHP's eval() to parse platform settings from the database. An attacker with admin access (obtainable via Advisory 1) can inject arbitrary PHP code into the settings, which is then executed when any user (including unauthenticated) requests /platform-config/list. This vulnerability is fixed in 2.0.0-RC.3.