CVE-2026-33686: code16 sharp · Path Traversal
Affects code16 sharpSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 9.20.0 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.20.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade sharp and code16/sharp to 9.20.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| code16sharp | Affected
| Fixed in
|
GitHubcode16/sharppkg:github/code16/sharpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Sharp version 9.20.0, which properly sanitizes file extensions and prevents path traversal. Users should upgrade to version 9.20.0 or later to remediate this vulnerability. Patch status is confirmed by the vendor's versioning and description.
Description
CVE-2026-33686 is a path traversal vulnerability in the Sharp content management framework for Laravel, affecting versions prior to 9.20.0. The vulnerability arises from improper sanitization of file extensions in the FileUtil class, allowing path separators to be passed into the storage layer. This can lead to unauthorized file access or modification. The issue is fixed in version 9.20.0 by changing the extension extraction method and applying strict sanitization. The vulnerability has a high severity with a CVSS score of 8.8.