Skip to main content
VulnerabilityPublished Updated

CVE-2026-33689: neutrinolabs xrdp · Out-of-bounds Read

Affects neutrinolabs xrdpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 0.10.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade xrdp and neutrinolabs/xrdp to 0.10.6.

Affected software

ProductAffectedFixed in
neutrinolabsxrdpAffected
  • <0.10.6
Fixed in
  • 0.10.6
GitHubneutrinolabs/xrdppkg:github/neutrinolabs/xrdpOther threatsAffected
  • <0.10.6
Fixed in
  • 0.10.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade xrdp to version 0.10.6 or later, where this vulnerability is fixed. Since this is not a cloud service, users must apply the patch themselves. Patch status is confirmed by the vendor's fix in version 0.10.6.

Description

xrdp is an open source RDP server. Versions through 0.10.5 have an out-of-bounds read vulnerability in the pre-authentication RDP message parsing logic. A remote, unauthenticated attacker can trigger this flaw by sending a specially crafted sequence of packets during the initial connection phase. This vulnerability results from insufficient validation of input buffer lengths before processing dynamic channel communication. Successful exploitation can lead to a denial-of-service (DoS) condition via a process crash or potential disclosure of sensitive information from the service's memory space. This issue has been fixed in version 0.10.6.

References

Community reviews

Loading reviews…