CVE-2026-33728: DataDog dd-trace-java · Deserialization of Untrusted Data
Affects DataDog dd-trace-javaSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.60.3 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.60.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade dd-trace-java and com.datadoghq/dd-trace-java to 1.60.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DataDogdd-trace-java | Affected
| Fixed in
|
Mavencom.datadoghq/dd-trace-javapkg:maven/com.datadoghq/dd-trace-javaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading dd-trace-java to version 1.60.3 or later for JDK versions 8u121 through 16. For JDK 17 and later, no action is required, though upgrading is recommended. For JDK versions earlier than 8u121 where serialization filters are unavailable, apply the workaround by setting the environment variable DD_INTEGRATION_RMI_ENABLED=false to disable the vulnerable RMI integration. These steps effectively mitigate the vulnerability.
Description
CVE-2026-33728 is a critical deserialization vulnerability in DataDog's dd-trace-java agent versions 0.40.0 through prior to 1.60.3. The vulnerability arises from the RMI instrumentation registering a custom endpoint that deserializes incoming data without applying serialization filters on JDK 16 and earlier. Exploitation requires that dd-trace-java is attached as a Java agent on a vulnerable JDK version, a network-reachable JMX/RMI port is configured, and a gadget-chain-compatible library is present on the classpath. Successful exploitation could lead to remote code execution. For JDK 17 and later, no action is required, but upgrading is recommended. For vulnerable versions, upgrading to dd-trace-java 1.