CVE-2026-33735: franklioxygen MyTube · Improper Authorization
Affects franklioxygen MyTubeSource CVE Database V5
Public exploit available · CVSS 7.4 High : upgrade to 1.8.69 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.69
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 27 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade MyTube and franklioxygen/MyTube to 1.8.69.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| franklioxygenMyTube | Affected
| Fixed in
|
GitHubfranklioxygen/MyTubepkg:github/franklioxygen/MyTubeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MyTube to version 1.8.69 or later, where the authorization bypass vulnerability has been fixed. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-33735 is an authorization bypass vulnerability in franklioxygen MyTube versions prior to 1.8.69. It affects the /api/settings/import-database endpoint, allowing attackers with low-privilege credentials to upload and replace the entire SQLite database of the application. This leads to a full compromise of the application. The issue also affects other POST routes. Version 1.8.69 addresses this vulnerability.
References
- github.com/franklioxygen/MyTube/security/advisories/GHSA-63cf-662x-crp2 (opens in a new tab)
- github.com/franklioxygen/MyTube/commit/b7bf9b7960958c6c51f85fe50a2fc041a086c466 (opens in a new tab)
- github.com/franklioxygen/MyTube/blob/6ade838a46366174e2c030f856340f3856e03132/backend/src/middleware/roleBasedSettingsMiddleware.ts (opens in a new tab)