CVE-2026-33753: trailofbits rfc3161-client · Improper Certificate Validation
Affects trailofbits rfc3161-clientSource CVE Database V5
Not known to be exploited · CVSS 6.2 Medium : upgrade to 1.0.6 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.6
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade trailofbits rfc3161-client to 1.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| trailofbitsrfc3161-client | Affected
| Fixed in
|
PyPIrfc3161-clientpkg:pypi/rfc3161-clientOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade rfc3161-client to version 1.0.6 or later, where this vulnerability is fixed. Patch status is not explicitly stated beyond this version update, so users should verify they are running 1.0.6 or newer. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-33753 is an authorization bypass vulnerability in the rfc3161-client Python library prior to version 1.0.6. The flaw arises from improper certificate validation during signature verification, allowing an attacker to impersonate a trusted Time-Stamping Authority (TSA). This is achieved by exploiting a logic error in extracting the leaf certificate from an unordered PKCS#7 certificate bag, enabling the attacker to append a spoofed certificate that meets the required common_name and Extended Key Usage (EKU) criteria. The library then incorrectly validates authorization rules against the forged certificate while verifying the cryptographic signature against a legitimate TSA certificate, bypassing TSA authorization pinning. The vulnerability has a CVSS 3.1 score of 6.2 (medium severity) and is fixed in version 1.0.