CVE-2026-33889: apostrophecms apostrophe · Cross-site Scripting
Affects apostrophecms apostropheSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.29.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.29.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade apostrophecms apostrophe to 4.29.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| apostrophecmsapostrophe | Affected
| Fixed in
|
AI-suggested
This vulnerability has been fixed in ApostropheCMS version 4.29.0. Users should upgrade to version 4.29.0 or later to remediate this issue. Until upgraded, restrict editor privileges and avoid loading untrusted draft content in administrative sessions.
Description
ApostropheCMS versions 4.28.0 and earlier contain a stored cross-site scripting (XSS) vulnerability in the @apostrophecms/color-field module. This flaw allows an editor to inject malicious JavaScript by bypassing color value validation and inserting unsanitized input into style tags. The vulnerability can lead to session hijacking, cookie theft, and privilege escalation if an administrator views the affected content. The issue is fixed in version 4.29.0.