Skip to main content
VulnerabilityPublished Updated

CVE-2026-33896: digitalbazaar forge · Improper Certificate Validation

Affects digitalbazaar forgeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High : upgrade to 1.4.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade forge and @digitalbazaar/forge to 1.4.0.

Affected software

ProductAffectedFixed in
digitalbazaarforgeAffected
  • <1.4.0
Fixed in
  • 1.4.0
npm@digitalbazaar/forgepkg:npm/@digitalbazaar/forgeOther threatsAffected
  • <1.4.0
Fixed in
  • 1.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in node-forge version 1.4.0. Users and organizations should upgrade to version 1.4.0 or later to remediate this vulnerability. The vendor advisory from Red Hat confirms the issue and the availability of patches in their affected products. No additional mitigation steps are indicated beyond applying the official fix.

Description

Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. Prior to version 1.4.0, `pki.verifyCertificateChain()` does not enforce RFC 5280 basicConstraints requirements when an intermediate certificate lacks both the `basicConstraints` and `keyUsage` extensions. This allows any leaf certificate (without these extensions) to act as a CA and sign other certificates, which node-forge will accept as valid. Version 1.4.0 patches the issue.

References

Community reviews

Loading reviews…