Skip to main content
CVE-2026-33945VulnerabilityPublished

CVE-2026-33945: lxc incus · Path Traversal

Affects lxc incusSource CVE Database V5

0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 6.23.0 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.23.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade incus and lxc/incus to 6.23.0.

Affected software

ProductAffectedFixed in
lxcincusAffected
  • <6.23.0
Fixed in
  • 6.23.0
GitHublxc/incuspkg:github/lxc/incusOther threatsAffected
  • <6.23.0
Fixed in
  • 6.23.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Incus to version 6.23.0 or later, where this path traversal vulnerability is fixed. No other mitigations are indicated. Patch status is confirmed fixed in version 6.23.0.

Description

CVE-2026-33945 is a critical path traversal vulnerability in the Incus container and virtual machine manager prior to version 6.23.0. It allows an attacker with limited privileges to write arbitrary files as root outside the intended credentials directory by exploiting the way Incus parses systemd credential configuration keys. This can lead to privilege escalation and denial of service. The vulnerability is fixed in version 6.23.0.

References

Community reviews

Loading reviews…