CVE-2026-33979: AhmedAdelFahim express-xss-sanitizer · Permissive List of Allowed Inputs
Affects AhmedAdelFahim express-xss-sanitizerSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 2.0.2 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade AhmedAdelFahim express-xss-sanitizer to 2.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AhmedAdelFahimexpress-xss-sanitizer | Affected
| Fixed in
|
npmexpress-xss-sanitizerpkg:npm/express-xss-sanitizerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users of express-xss-sanitizer should upgrade to version 2.0.2 or later, where the sanitization logic correctly respects restrictive configurations. Patch status is not explicitly confirmed beyond the version mention, so users should consult the official project repository or vendor advisory for the latest remediation guidance.
Description
Express XSS Sanitizer is Express 4.x and 5.x middleware which sanitizes user input data (in req.body, req.query, req.headers and req.params) to prevent Cross Site Scripting (XSS) attack. A vulnerability has been identified in versions prior to 2.0.2 where restrictive sanitization configurations are silently ignored. In version 2.0.2, the validation logic has been updated to respect explicitly provided empty configurations. Now, if allowedTags or allowedAttributes are provided (even if empty), they are passed directly to sanitize-html without being overridden.
References
- github.com/AhmedAdelFahim/express-xss-sanitizer/security/advisories/GHSA-3843-rr4g-m8jq (opens in a new tab)
- github.com/AhmedAdelFahim/express-xss-sanitizer/commit/5623009ef11dcf095c163a38dea07b9cc22ad19f (opens in a new tab)
- github.com/AhmedAdelFahim/express-xss-sanitizer/releases/tag/v2.0.2 (opens in a new tab)