CVE-2026-34052: jupyterhub ltiauthenticator · Memory Leak
Affects jupyterhub ltiauthenticatorSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 1.6.3 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade jupyterhub ltiauthenticator to 1.6.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jupyterhubltiauthenticator | Affected
| Fixed in
|
PyPIltiauthenticatorpkg:pypi/ltiauthenticatorOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the ltiauthenticator component of JupyterHub to version 1.6.3 or later, where this memory exhaustion issue has been patched. No other mitigations are indicated. Patch status is confirmed by the vendor advisory stating the issue is fixed in version 1.6.3.
Description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.