Skip to main content
VulnerabilityPublished

CVE-2026-34064: nimiq-account · Integer Underflow

Affects nimiq-accountSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.3.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade nimiq-account and github/nimiq/nimiq-account to 1.3.0.

Affected software

ProductAffectedFixed in
nimiqnimiq-accountAffected
  • <1.3.0
Fixed in
  • 1.3.0
crates.iogithub/nimiq/nimiq-accountpkg:cargo/github/nimiq/nimiq-accountOther threatsAffected
  • <1.3.0
Fixed in
  • 1.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is included in nimiq-account version 1.3.0. Users should upgrade to version 1.3.0 or later to remediate this issue. No workarounds are available.

Description

CVE-2026-34064 is an integer underflow vulnerability in the nimiq-account Rust implementation prior to version 1.3.0. The issue occurs in the VestingContract::can_change_balance function, where an underflow panic can crash the node if an attacker creates a vesting contract with a total_amount exceeding the actual contract balance. This leads to a panic during mempool admission and block processing when an outgoing transaction triggers the vulnerable code path. The vulnerability has a medium severity with a CVSS score of 5.3. A patch fixing this issue is included in version 1.3.0.

References

Community reviews

Loading reviews…