CVE-2026-34080: flatpak xdg-dbus-proxy · Improper Validation of Unsafe Equivalence in Input
Affects flatpak xdg-dbus-proxySource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 0.1.7 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.1.7
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade xdg-dbus-proxy and flatpak/xdg-dbus-proxy to 0.1.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| flatpakxdg-dbus-proxy | Affected
| Fixed in
|
GitHubflatpak/xdg-dbus-proxypkg:github/flatpak/xdg-dbus-proxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade flatpak xdg-dbus-proxy to version 0.1.7 or later where this vulnerability is fixed. Since the vendor advisory confirms the fix in 0.1.7, applying this official update is the recommended remediation. No other mitigation or temporary workaround is indicated.
Description
xdg-dbus-proxy is a filtering proxy for D-Bus connections. Prior to 0.1.7, a policy parser vulnerability allows bypassing eavesdrop restrictions. The proxy checks for eavesdrop=true in policy rules but fails to handle eavesdrop ='true' (with a space before the equals sign) and similar cases. Clients can intercept D-Bus messages they should not have access to. This vulnerability is fixed in 0.1.7.