Skip to main content
VulnerabilityPublished

CVE-2026-34206: libops captcha-protect · Cross-site Scripting

Affects libops captcha-protectSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.12.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade captcha-protect and github.com/libops/captcha-protect to 1.12.2.

Affected software

ProductAffectedFixed in
libopscaptcha-protectAffected
  • <1.12.2
Fixed in
  • 1.12.2
Gogithub.com/libops/captcha-protectpkg:golang/github.com/libops/captcha-protectOther threatsAffected
  • <1.12.2
Fixed in
  • 1.12.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade libops captcha-protect to version 1.12.2 or later, where this reflected XSS vulnerability is patched. No other mitigations are specified or required once the update is applied.

Description

Captcha Protect is a Traefik middleware to add an anti-bot challenge to individual IPs in a subnet when traffic spikes are detected from that subnet. Prior to version 1.12.2, a reflected cross-site scripting (XSS) vulnerability exists in github.com/libops/captcha-protect. The challenge page accepted a client-supplied destination value and rendered it into HTML using Go's text/template. Because text/template does not perform contextual HTML escaping, an attacker could supply a crafted destination value that breaks out of the hidden input attribute and injects arbitrary script into the challenge page. This issue has been patched in version 1.12.2.

References

Community reviews

Loading reviews…