Skip to main content
VulnerabilityPublished

CVE-2026-34211: nyariv SandboxJS · Uncontrolled Recursion

Affects nyariv SandboxJSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.8.36 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.36
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade SandboxJS and nyariv/sandboxjs to 0.8.36.

Affected software

ProductAffectedFixed in
nyarivSandboxJSAffected
  • <0.8.36
Fixed in
  • 0.8.36
npmnyariv/sandboxjspkg:npm/nyariv/sandboxjsOther threatsAffected
  • <0.8.36
Fixed in
  • 0.8.36

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to SandboxJS version 0.8.36 or later, where this uncontrolled recursion vulnerability is fixed. Patch status is confirmed by the vendor's versioning information. No other mitigations are indicated.

Description

CVE-2026-34211 is a medium severity vulnerability in the nyariv SandboxJS JavaScript sandboxing library versions prior to 0.8.36. It involves uncontrolled recursion in the parser's restOfExp function and the lispify/lispifyExpr call chain. An attacker can cause a Node.js process to crash by supplying deeply nested expressions, triggering a RangeError due to maximum call stack size exceeded. This results in denial of service by terminating the affected process. The issue is fixed in version 0.8.36.

References

Community reviews

Loading reviews…