Skip to main content
VulnerabilityPublished

CVE-2026-34216: Ctrlpanel-gg panel · Unsafe Reflection

Affects Ctrlpanel-gg panelSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.6 Medium : upgrade to 1.2.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade panel and ctrlpanel-gg/panel to 1.2.0.

Affected software

ProductAffectedFixed in
Ctrlpanel-ggpanelAffected
  • <1.2.0
Fixed in
  • 1.2.0
Packagistctrlpanel-gg/panelpkg:composer/ctrlpanel-gg/panelOther threatsAffected
  • <1.2.0
Fixed in
  • 1.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in CtrlPanel version 1.2.0. Users should upgrade to version 1.2.0 or later to remediate this issue. Until upgrading, restrict admin access to trusted users only.

Description

CtrlPanel is open-source billing software for hosting providers. In versions 1.1.1 and prior, the admin settings update endpoint accepted a fully qualified class name directly from user-supplied request input and used it for dynamic static method calls and object instantiation without any allowlist validation, allowing for authenticated Remote Code Execution. An authenticated admin-level user could supply an arbitrary class name available in the Composer autoloader, potentially triggering unintended constructor or magic method execution. The update() method reads settings_class directly from the HTTP request and passed it to new $settings_class() and $settings_class::getValidations() without verifying that the provided value corresponds to a legitimate settings class: Because PHP resolves class names against the Composer autoloader at runtime, any autoloadable class in the application or its dependencies could be instantiated. Depending on the classes available in the dependency tree, this can trigger unintended side effects through constructors or magic methods (__construct, __toString, __wakeup), following a PHP object injection / gadget chain pattern. This issue has been fixed in version 1.2.0.

References

Community reviews

Loading reviews…