CVE-2026-34232: FirebirdSQL firebird · Improper Handling of Syntactically Invalid Structure
Affects FirebirdSQL firebirdSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 5.0.4 : patch FirebirdSQL firebird soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.4, 4.0.7, 3.0.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade firebird and firebirdsql/firebird to 5.0.4, 4.0.7 or 3.0.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FirebirdSQLfirebird | Affected
| Fixed in
|
| FirebirdSQLfirebird | Affected
| Fixed in
|
| FirebirdSQLfirebird | Affected
| Fixed in
|
GitHubfirebirdsql/firebirdpkg:github/firebirdsql/firebirdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in FirebirdSQL versions 3.0.14, 4.0.7, and 5.0.4. Users should upgrade to these or later versions to remediate the vulnerability. Since this is not a cloud service, patching the affected software installations is required. Patch status is confirmed by the vendor's versioning information.
Description
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, the xdr_status_vector() function does not handle the isc_arg_cstring type when decoding an op_response packet, causing a server crash when one is encountered in the status vector. An unauthenticated attacker can exploit this by sending a crafted op_response packet to the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
References
- github.com/FirebirdSQL/firebird/security/advisories/GHSA-7jq3-6j3c-5cm2 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v3.0.14 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v4.0.7 (opens in a new tab)
- github.com/FirebirdSQL/firebird/releases/tag/v5.0.4 (opens in a new tab)