Skip to main content
VulnerabilityPublished Updated

CVE-2026-34235: pjsip pjproject · Out-of-bounds Read

Affects pjsip pjprojectSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.17 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pjproject and pjsip/pjproject to 2.17.

Affected software

ProductAffectedFixed in
pjsippjprojectAffected
  • <2.17
Fixed in
  • 2.17
GitHubpjsip/pjprojectpkg:github/pjsip/pjprojectOther threatsAffected
  • <2.17
Fixed in
  • 2.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pjproject to version 2.17 or later where this vulnerability is patched. If upgrading is not feasible immediately, disable the VP9 codec to mitigate the risk. No other vendor advisories or patches are indicated, so check the official pjproject releases for confirmation and updates.

Description

PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, a heap out-of-bounds read vulnerability exists in PJSIP's VP9 RTP unpacketizer that occurs when parsing crafted VP9 Scalability Structure (SS) data. Insufficient bounds checking on the payload descriptor length may cause reads beyond the allocated RTP payload buffer. This issue has been patched in version 2.17. A workaround for this issue involves disabling VP9 codec if not needed.

References

Community reviews

Loading reviews…