Skip to main content
VulnerabilityPublished

CVE-2026-34246: Ctrlpanel-gg panel · Basic XSS

Affects Ctrlpanel-gg panelSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.2.0 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade panel and ctrlpanel-gg/panel to 1.2.0.

Affected software

ProductAffectedFixed in
Ctrlpanel-ggpanelAffected
  • <1.2.0
Fixed in
  • 1.2.0
GitHubctrlpanel-gg/panelpkg:github/ctrlpanel-gg/panelOther threatsAffected
  • <1.2.0
Fixed in
  • 1.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is resolved in CtrlPanel version 1.2.0. Users should upgrade to version 1.2.0 or later to remediate the issue. No vendor advisory is provided to indicate alternative mitigations or temporary fixes. Until upgraded, restrict role creation and editing permissions to trusted administrators only to reduce risk.

Description

CtrlPanel is open-source billing software for hosting providers. Versions 1.1.1 and prior contain a Stored Cross-Site Scripting (XSS) vulnerability exists in the admin role management interface. In app/Http/Controllers/Admin/RoleController.php, the datatable() method interpolates $role->name and $role->color directly into a <span> element's HTML and style attribute without sanitization, and the chained .rawColumns(['actions', 'name']) call instructs DataTables to render the name column as raw HTML, bypassing automatic output escaping. An admin with role creation or edit permissions can inject a payload such as <img src=x onerror="alert('XSS_POC')"> into the name or color fields, which is persisted to the database and executes in the browser of every admin who loads the /admin/roles page. This enables session hijacking via cookie theft, credential harvesting through fake login prompts or keyloggers, lateral privilege escalation by performing admin actions on behalf of victims, and a persistent backdoor that re-executes on every page load until the malicious role record is removed. This issue has been resolved in version 1.2.0.

References

Community reviews

Loading reviews…