Skip to main content
VulnerabilityPublished Updated

CVE-2026-34355: Apache HTTP Server · Heap-based Buffer Overflow

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 2.4.68 : patch Apache HTTP Server soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 67% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • >=2.4.0 <=2.4.67
Fixed in–

AI-suggested

A fix is available in Apache HTTP Server version 2.4.68. Users should upgrade to this version to remediate the vulnerability. If upgrading is not immediately possible, the vendor advisory recommends disabling the mod_proxy_html module if it is not essential. If mod_proxy_html is required, restrict its use to trusted backend servers only by employing network segmentation and access controls. After configuration changes, reload the Apache HTTP Server service to apply the changes. These mitigations reduce the risk until the official fix is applied.

Description

A buffer overflow in mod_proxy_html in Apache HTTP Server 2.4.67 and earlier allows an attack by an untrusted backend. Users are recommended to upgrade to version 2.4.68, which fixes this issue.

References

Community reviews

Loading reviews…