CVE-2026-34379: AcademySoftwareFoundation openexr · Incorrect Type Conversion or Cast
Affects AcademySoftwareFoundation openexrSource CVE Database V5
Not known to be exploited · CVSS 7.1 High · fixed in 3.4.9 : patch AcademySoftwareFoundation openexr soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.9, 3.3.9, 3.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade openexr and academysoftwarefoundation/openexr to 3.4.9, 3.3.9 or 3.2.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AcademySoftwareFoundationopenexr | Affected
| Fixed in
|
| AcademySoftwareFoundationopenexr | Affected
| Fixed in
|
| AcademySoftwareFoundationopenexr | Affected
| Fixed in
|
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions 3.2.7, 3.3.9, and 3.4.9 of openexr address this vulnerability. Users should upgrade to one of these versions to remediate the issue. No vendor advisory indicates alternative mitigations or that no action is required. Patch status is confirmed by the vendor advisory. No cloud service remediation applies as this is a library.
Description
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, a misaligned memory write vulnerability exists in LossyDctDecoder_execute() in src/lib/OpenEXRCore/internal_dwa_decoder.h:749. When decoding a DWA or DWAB-compressed EXR file containing a FLOAT-type channel, the decoder performs an in-place HALF→FLOAT conversion by casting an unaligned uint8_t * row pointer to float * and writing through it. Because the row buffer may not be 4-byte aligned, this constitutes undefined behavior under the C standard and crashes immediately on architectures that enforce alignment (ARM, RISC-V, etc.). On x86 it is silently tolerated at runtime but remains exploitable via compiler optimizations that assume aligned access. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.
References
- github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-w88v-vqhq-5p24 (opens in a new tab)
- github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.2.7 (opens in a new tab)
- github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.9 (opens in a new tab)
- github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.9 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-34379 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2455402 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34379.json (opens in a new tab)