CVE-2026-3438: Sonatype Nexus Repository · XSS or 'Cross-site Scripting'
Affects Sonatype Nexus RepositorySource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 3.91.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.91.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Sonatype Nexus Repository to 3.91.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SonatypeNexus Repository | Affected
| Fixed in
|
Mavenorg.sonatype.nexus/nexus-repositorypkg:maven/org.sonatype.nexus/nexus-repositoryOther threats | Affected
| Fixed in– |
CPE configurations (148)
cpe:2.3:a:sonatype:nexus_repository_manager:3.0.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.0.1:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.0.2:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.1.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.2.0:*:*:*:*:*:*:*cpe:2.3:a:sonatype:nexus_repository_manager:3.2.1:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
CVE-2026-3438 is a reflected cross-site scripting (XSS) vulnerability in Sonatype Nexus Repository versions 3.0.0 through 3.90.2. It allows unauthenticated remote attackers to execute arbitrary JavaScript in a victim's browser via a specially crafted URL. Exploitation requires user interaction. The vulnerability has a medium severity with a CVSS score of 5.1.