Skip to main content
VulnerabilityPublished Updated

CVE-2026-34483: Apache Tomcat · Improper Encoding or Escaping of Output

Affects Apache TomcatSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache TomcatAffected
  • >=11.0.0-M1 <=11.0.20
  • >=10.1.0-M1 <=10.1.53
  • >=9.0.40 <=9.0.116
  • >=8.5.84 <=8.5.100
Fixed in–
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • >=9.0.40 <=9.0.116
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade Apache Tomcat to versions 11.0.21, 10.1.54, or 9.0.117 to remediate this vulnerability. No additional mitigation steps are indicated beyond applying the official updates.

Description

An improper encoding or escaping of output vulnerability exists in the JsonAccessLogValve component of Apache Tomcat. This affects multiple versions across Tomcat 9.0, 10.1, and 11.0 branches. The vulnerability allows for potential exposure of sensitive data due to improper handling of output encoding. Fixed versions have been released to address this issue.

References

Community reviews

Loading reviews…