CVE-2026-34501: Apache Portable Runtime Utility · Heap-based Buffer Overflow
Affects Apache Portable Runtime UtilitySource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 1.6.4 : patch Apache Portable Runtime Utility soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Portable Runtime Utility | Affected
| Fixed in– |
AI-suggested
Users should upgrade to Apache Portable Runtime Utility version 1.6.4 or later to remediate this vulnerability. Patch status is confirmed by the vendor's recommendation to upgrade. No other mitigations are specified.
Description
CVE-2026-34501 is a heap-based buffer overflow vulnerability in the Apache Portable Runtime Utility's Redis client. It affects versions from 1.6.0 through 1.6.3. The issue can cause a denial of service by crashing the application. Users are advised to upgrade to version 1.6.4, which addresses the vulnerability.